C++ написать программу, используя два раза while, которая выдает следующее: * ** *** я написал, но не работает. может найдете ошибку в моей? (ошибка не в синтаксисе, а в выдаче результата) #include int main() { int verticaldown=0; int horizontalright=0; int countcolumns=1; while(verticaldown< 8) { while(horizontalright { std: : cout < < "*"; horizontalright++; } countcolumns++; verticaldown++; std: : cout < < "\n"; } return 0; }
#include <iostream>using namespace std;
int main()
{
const int N = 8;
char matrix[N][N];
for (int i = 0; i < N; i++) {
for (int j = 0; j < N; j++) {
matrix[i][j] = 0;
if (i > j) {
matrix[i][j] = '*';
}
cout << matrix[i][j] << " ";
}
cout << endl;
}
return 0;
}