1написать программу, которая находит в массиве значения, повторяющиеся два и более раз, и показывает их на экран. 2 написать программу, которая находит в массиве самое маленькое нечетное число и показывает его на экран. для всех : размер массива вводит пользователь. элементы массива рандомно в диапазоне [ 13; 27 ].

alihanova1 alihanova1    1   03.09.2019 02:20    8

Ответы
GolduckChannel GolduckChannel  06.10.2020 13:43
Int main()

  int  
    numOfEl,          // number of elements in the array
    minNum = 28,  // minimal number in the array   
    *mainArray,      // main array   
    cntArray[15];    // array for counting the repeated numbers

    std::cout << "Input the number of the elements: "; 
    std::cin >> numOfEl;

    mainArray = new int[numOfEl];

    for (int i = 0; i < 15; i++)
      cntArray[i] = 0;   

    for (int i = 0; i < numOfEl; i++)
    {
      cntArray[(mainArray[i] = rand() % 15 + 13) - 13]++;

      if (mainArray[i] < minNum && mainArray[i] % 2 != 0)
        minNum = mainArray[i]; 
    }

#ifdef _DEBUG
    std::cout << "Array: ";
   
    for (int i = 0; i < numOfEl; i++)
      std::cout << mainArray[i] << ";" << std::endl;
#endif

    std::cout << "Repeated numbers: ";
    for (int i = 0; i < numOfEl; i++) 
      if (cntArray[i] >= 2)
        std::cout << i + 13 << "; ";

    std::cout << std::endl << "Minimal number: " << minNum << std::endl;

    system("pause");
   
   return 0;
} /* End of the 'main' function */
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика