№1 составить программу формирования и вывода на экран в строку с тремя знаками после запятой массива, заданного 8-ю вещественными числами из отрезка [-20; 20) №2 составить программу формирования и вывода на кран в обратном порядке массива,заданного 13 цельными числами из отрезка [5,18] №3 составить программу формирования и вывода на экран в столбец массива, зданного 7 цельными числами из отрезка [104,128]

Akri2532 Akri2532    3   16.06.2019 05:30    0

Ответы
Елька165 Елька165  13.07.2020 01:32
1. Program enot;
Var A: array[1..8] of real;
 i:integer;
begin
for i:= 1 to 8 do
begin
a[i]:=random(41)-20;
writeln(a[i]:8:3);
end;
end.

2. Program fg;
Var a: array [1..13] of integer;
i:integer;
begin
writeln('первоночальный массив: ');
for i:= 1 to 13 do
begin
a[i]:=random(13)+5;
writeln(a[i], ' ');
end;
writeln('получившийся  массив: ');
for i:= 13 downto 1 do
writeln(a[i],' ');
end.

3. 
Program enot;
Var a: array [1..7] of integer;
i:integer;
begin
for i:= 1 to 7 do
begin
a[i]:=random(25)+104;
writeln(a[i]);
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика