Напишите условие необходимое для работы следующей программы. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, оканчивающихся на 5 или на 0.

netunikaa netunikaa    1   09.05.2020 23:50    0

Ответы
nikitaximik nikitaximik  14.10.2020 12:33

Программу я написал на PascalABCnet

Объяснение:

program ex_1;

var n,i,k,a:integer;  //n-номер числа i-счетчик k-количество чисел a-число

begin

 writeln('Введите количество чисел');

 readln(n);

 for i:=1 to n do

 begin

   writeln('Введите ',i,' число');

   readln(a);

   if (a mod 5=0) or (a mod 5=5) then

     k:=k+1;

 end;

 writeln('Количество чисел, оканчивающихся на 0 или 5: ',k);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика