Вмассиве найдите минимальный и максимаксимальный элементы среди элементов с чётными индексами . в паскале

Каракат11111 Каракат11111    2   12.09.2019 14:50    3

Ответы
nomar nomar  04.08.2020 06:45
PascalABC.NET
Версия 3.3. сборка 1583 (25.11.2017)

var 
 n:integer;
 a:array[1..100] of integer;
begin
 write('Введите размер массива (n<100): ');readln(n);
 var max:=0;
 var min:=101;
 for var i:=1 to n do
 begin
  a[i]:=random(0,100);
  write(a[i],' ');
  if i mod 2=0 then
   if a[i]>max then max:=a[i]
   else
    if a[i]<min then min:=a[i];
 end;
 writeln;
 writeln('Максимальный - ',max);
 writeln('Минимальный - ',min);
 readln;
end.

Пример:

Введите размер массива (n<100): 10
15 32 90 97 35 62 52 37 5 63 
Максимальный - 97
Минимальный - 37
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика