Составьте программу на вычисление суммы числа, цикл с предусловием

юля2713 юля2713    2   19.07.2019 03:30    2

Ответы
anastasia1medvedeva anastasia1medvedeva  13.08.2020 19:37
Var
s, n: integer;
begin
readln(n);
s:=0;
while n > 0 do
begin
s:=s + n mod 10;
n:=n div 10;
end;
writeln(s);
end.
ПОКАЗАТЬ ОТВЕТЫ
grachev791 grachev791  13.08.2020 19:37
Program Znanija;
uses crt;

var a,b : integer;

begin
readln(b);
a:=0;
while b > 0 do
begin
a:=a + b mod 10;
b:=b div 10;
end:
writeln('ответ',a );
end
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика