Составьте программу, которая генерирует и выводит на экран длины сторон катетов прямоугольного треугольника, не превыщающих 10 см. Программа должна подсчитать длину гипотенузы этого треугольника, его площадь и периметр и вывести их на экран. Затем эти вычисленные значения следует округлить и вывести результат на экран в отдельной строке (Phyton/Питон)

медвежонок41 медвежонок41    2   28.11.2021 14:54    1

Ответы
кот1555 кот1555  04.01.2022 06:40

import math

import random

a = random.randint(2,10)

b = random.randint(2,10)

while a == b:

   a = random.randint(2,10)

   b = random.randint(2,10)

print("a =", a, "см", "b =", b, "см.")

c = math.sqrt(a**2+b**2)

print("c =",'%.1f' % c, "см.")

p = a+b+c

print("P =",'%.1f' % p, "см.")

s = (a*b)/2

print("S =",'%.1f' % s, "см^2.")

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика