tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу
Составить программу нахождения суммы трехзначных чисел кратных 5 и 7 и 9
annachanskp06yi3
2 25.07.2019 09:40
4
Ответы
Nicolay93
25.08.2020 13:48
//Pascal ABC.NET v3.1 сборка 1172
//Продвинутый вариант
begin
writeln(range(100,999).Where(x -> x mod 7=0).Where(x -> x mod 9=0).Where(x -> x mod 5=0).Sum);
end.
//"Школьный" вариант
Var
i,s:integer;
begin
for i:=100 to 999 do
if (i mod 5=0) and (i mod 7=0) and (i mod 9=0) then s:=s+i;
writeln(s);
end.
Вывод:
1890
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
situan4
07.07.2019 20:00
Каково было количество возможных событий, если после реализации полного из них мы получили количество информации равное 7 бит?...
syromyatnikov05
16.06.2019 23:40
Для записи информации об объекте пользователь использует из 30 букв и знаков. сколько битов понадобится для того, чтобы закодировать один символ данного алфавита? а. 5 б. 30 в....
NikaHikikomori
16.06.2019 23:40
Папка, находящаяся в другой папке, называется: вложенной родительской каталогом корневой...
KOSHAPLAY27082007
24.08.2019 06:20
Составить и написпть алгоритм 4 класс...
ksyusa41
22.11.2020 18:27
15 - Электронные таблицы 1. Как называется горизонтальный ряд ячеек электронной таблицы? ответ: введите строку 2. Как называется вертикальный ряд ячеек электронной таблицы? ответ:...
hcggchhcfuj
22.11.2020 18:27
Номер 77 Надо схему построить...
LONNI34
14.08.2019 18:00
Какие цветочные растения из красной книги растут в нашем крае?...
akdavletovaalfia
14.08.2019 18:00
Люди ! вообще не получается : ( : учитель проверяет работы письменного экзамена. изначально на его столе нет ни одной работы. иногда приносят стопку работ с подряд идущими номерами,...
раопп
14.08.2019 18:00
Как решить уравнение 357z-149z-1843=11469...
marina2355
14.08.2019 18:00
Одна сторона треугольника в 5 раз меньше второй и на 28 дециметр меньше третьей найдите стороны треугольника если его периметр равен 84 дециметр...
Популярные вопросы
Один з найбільших національних парківсвіту Серенгеті знаходиться на території...
2
Внимательно прочитайте текст и ответьте на вопросы. Из турецкой статистики XVI...
3
Як відреагував Герасим на прохання Параски запрягти коней, щоб поїхати до церкви:...
3
Спортсмен повинен пробігти крос та, не зупиняючись, перепливти озеро. З якою...
2
Что получали воины за военную службу в Османской империи? Укажите правильный...
3
Задание на фото , прям оч нужно...
2
2. В основании тетраэдра лежит прямоугольный треугольник, гипотенуза которого...
2
Встановіть відповідність між поняттям та його визначенням. 1. мислення2. пам’ять3....
3
Рослина гарбуза з білими дископодібними плодами, яка схрещена з рослиною, що...
2
Одноклітинні водорост б живлення і поглинання органічних речовин...
3
//Продвинутый вариант
begin
writeln(range(100,999).Where(x -> x mod 7=0).Where(x -> x mod 9=0).Where(x -> x mod 5=0).Sum);
end.
//"Школьный" вариант
Var
i,s:integer;
begin
for i:=100 to 999 do
if (i mod 5=0) and (i mod 7=0) and (i mod 9=0) then s:=s+i;
writeln(s);
end.
Вывод:
1890