Составить программу, которая выводит на экран названия не менее трех городов

naval2018 naval2018    2   19.09.2019 08:40    3

Ответы
Рубка2006 Рубка2006  21.08.2020 11:38
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var a:array[1..3] of string;
  var l:array[1..3] of integer;
  for var i:=1 to 3 do begin
    Write('Город ',i,': '); Readln(a[i]);
    l[i]:=Length(a[i])
    end;
  var imin:=1; var imax:=1;
  for var i:=2 to 3 do begin
    if l[i]<l[imin] then imin:=i;
    if l[i]>l[imax] then imax:=i
    end;
  Writeln('Самое длинное название- ',a[imax]);
  Writeln('Самое короткое название- ',a[imin])
end.

Тестовое решение
Город 1: Москва
Город 2: Минск
Город 3: Киев
Самое длинное название- Москва
Самое короткое название- Киев
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика