Программирование в с++. в массиве в(12) все нецелые элементы из отрезка [a,b] занесите в массив с и найдите минимальный элемент массива с.

leogorec06 leogorec06    1   24.05.2019 10:50    7

Ответы
Falkon5511 Falkon5511  20.06.2020 07:56
Как я понял то а и b - это индексы начала и конца перебора данного массива, если это так то решение таково :
#include <iostream>
using namespace std;
 int main()
{
int B[12];
for(int i=0;i<12;i++)
cin>>B[i]; //занесение в первоначальный массив В
int a,b;
cin>>a>>b; //считывание необходимого промежутка
int C[b-a]; //обьявление конечного массива
for(int i=b-a,k=0;i<b;i++,k++)
{
С[k]=B[i]; // перенос нужных значений
}
int min=C[0]; //переменная в которой будет в итоге храниться минимальное знач.
for(int i=0;i<(b-a);i++)
{
if(C[i]<min) //нахождение минимального элемента
min=C[i];
}
cout<<min; //вывод минимального элемента
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика