tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Пользователь вводит
Пользователь вводит целочисленный массив из 25 элементов . вычислить сумму элементов массива, меньших -12
АмелияРайс
2 17.07.2019 21:00
2
Ответы
Lulu84
21.09.2020 20:14
//Pascal ABC.NET v3.0 сборка 1111
Const
n=25;
Var
ar:array[1..n] of integer;
s,i:integer;
begin;
s:=0;
for i:=1 to n do
begin;
readln(ar[i]);
if ar[i]<12 then s:=s+ar[i];
end;
writeln('Sum=',s);
end.
Пример ввода:
1
2
...
9
-10
-11
..
-19
20
21
..
25
Пример вывода:
Sum=-100
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
vadimrusackeviVadim
16.06.2019 17:50
Реализуйте структуру данных стек . напишите программу, содержащую описание стека и моделирующую работу стека, реализовав все указанные здесь методы. программа считывает...
glushcovapolia
25.06.2019 03:00
Установить соответствие: ctrl+home что он выполняет...
angelinaosadchy
25.06.2019 02:50
Какие из следующих предложений являются высказываниями? определите их истинность. 1. наполеон был французским императором. 2.чему равно расстояние от земли до марса? 3....
Фиджиии
25.06.2019 02:50
Написать программу, вычисляющую сумму цифр в произведении трех целых числа a,b и c. входной файл в единственной строке файла содержатся три целых числа a,b и c, разделенных...
mikysya
25.06.2019 02:50
Для какого из значений числа x ложно высказывание: не (x = 5) или (x 6)? 1) 4 2) 5 3) 6 4) 7...
nikgum
25.06.2019 02:50
Пятизначные числа a,b,c,d. найти такие числа что, x mod a=b, x mod c=d (написать с дружественным интерфейсом)...
121e312r3214
25.06.2019 02:40
Для того кто разбирается в пк как выглядят недоступные в текущий момент пункты меню?...
innaecaln
25.06.2019 02:40
Составьте программу на языке паскаль используя массив найдите сумму положительных элементов массива...
Alex200488005553535
25.06.2019 02:40
Известно, что наибольший объем информации здоровый человек получает при : органов слуха обоняния осязания зрения вкуса выберите правильный ответ....
дашенька158
25.06.2019 02:40
Дано целое число n и набор из n чисел. найдите номер первого наибольшего и номер последнего наименьшего числа в наборе. ввод целое число n и набор из n чисел в одной строке....
Популярные вопросы
Решить : из сметаны получили две целых одну пятую- 2 1\5 кг масла , что...
2
Записать предложение со словом what s this?...
3
Боковая сторона равнобедренной трапеции описанной около окружности равна...
1
Углы мкр и рkn - смежные , кs - биссектриса угла ркn . найдите угол мкs...
3
Напишите сообщение музыкальных иллюстраций сверидова...
3
Туристы купили палатку рюкзак и спальные мешки половина стоимости покупка...
2
Кто хорошо понимает найдите корень уравнения 1 мин ус дальше дробь в...
1
Климатические особенности южной америки...
1
Турист км за 0,2, 7км за 2 часа и 1,7 км за 0,5 ч. на каком участке пути...
2
Ну неужели никто не знает! ! разность углов, соответственные стороны...
1
Const
n=25;
Var
ar:array[1..n] of integer;
s,i:integer;
begin;
s:=0;
for i:=1 to n do
begin;
readln(ar[i]);
if ar[i]<12 then s:=s+ar[i];
end;
writeln('Sum=',s);
end.
Пример ввода:
1
2
...
9
-10
-11
..
-19
20
21
..
25
Пример вывода:
Sum=-100