Почему не работает запись в паскале по : написать программу, подсчитывающую количество четных цифр, которые делятся на 4, в числе. вот запись, исправьте : program chisla; var a,b,k: integer; begin k: =0; writeln('введите число'); readln(a); repeat if(a mod 2=0)and(a mod 4=0)then k: =k+1 until a=0; writeln('количество чисел=',k) end.
begin
k:=0;
writeln('Введите число');
readln(a);
repeat
if (a mod 10) in [4,8] then k:=k+1;
a:=a div 10;
until a=0;
writeln('Количество чисел=',k)
end.
Введите число
24583
Количество чисел=2