По pascal abc ! поле шахматной доски определяется парой натуральных чисел, каждое из которых не превосходит восьми: первое число-номер вертикали(при счете слева направо), а второе-номер по горизонтали(при счете снизу вверх). с клавиатуры вводятся четыре числа a, b, c,d, каждое из которых не превосходит восьми. на поле ( a,b ) расположен слон. написать программу, которая выводит на экран true, если слон угрожает полю ( c,d ) false в противном случае. примечание. слон может перемещаться строго по диагонали на произвольное число клеток.

лосимус лосимус    3   03.06.2019 01:20    3

Ответы
GoldHorse GoldHorse  03.07.2020 15:13
Program slon;
var a, b, c, d:integer;
begin
a:=0; b:=0; c:=0; d:=0;
while (a<1) or (a>8) do begin write ('Введите число от 1 до 8, a='); readln (a); end;
while (b<1) or (b>8) do begin write ('Введите число от 1 до 8, b='); readln (b); end;
while (c<1) or (c>8) do begin write ('Введите число от 1 до 8, c='); readln (c); end;
while (d<1) or (d>8) do begin write ('Введите число от 1 до 8, d='); readln (d); end;
if abs(a-c)=abs(b-d) then write ('true') else write ('false');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика