Паскаль абс.составить программу для решения следующей : известный пират флинт положил некоторую сумму s в банк под 3% годовых. выведите на экран, через сколько лет сумма превысит 1,5s. начальное значение s вводится с клавиатуры. решать через while

UtkinaVioletta UtkinaVioletta    3   07.10.2019 23:50    15

Ответы
arinayakovenkop09u55 arinayakovenkop09u55  10.10.2020 02:50

program flint;

var s, s2, y: real;

begin;

readln(s);

s2 := s * 1.5;

while s < s2 do begin;

s := s * 1.03;

y := y + 1;

end;

writeln(y)

end.

ПОКАЗАТЬ ОТВЕТЫ
cmh3 cmh3  10.10.2020 02:50

Program n_1;

var s, m: real; n:integer;

begin

 read(s);

 n:=0; m:=s;

 while (m<=1.5*s) do begin

   m:=m*1.03;

   n:=n+1;

 end;

 writeln(n);

end.

Честно говоря, решение тут вообще не зависит от S. Всегда выводится одно и то же число - 14

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика