Нужно написать полноценную программу на паскале
Используя оператор условного перехода, напишите программу, которая:
1) классифицирует компьютерную сеть. Программа запрашивает у пользователя число компьютеров в сети и в зависимости от введенного количества выводит класс сети (если число ЭВМ меньше 256 - то это сеть класса С, от 256 до 65535 - сеть класса В, свыше 65535 - сеть класса А);
2) запрашивает у пользователя номер одного из весенних месяцев, и выводит количество дней в этом месяце. Программа должна проверять, является ли введенный месяц весенним;
3) выводит на экран приглашение: «Который час?», вводит с клавиатуры число X, имеющее смысл времени суток, и печатает слова «Доброе утро», «Добрый вечер», «Добрый день» в зависимости от введенного времени. Программа должна реагировать на ввод неправильного времени: меньше 0 или больше 24;

shakurovagaliya shakurovagaliya    2   08.04.2020 13:21    12

Ответы
evgen90079 evgen90079  23.08.2020 19:48

1.

var

a : integer;

begin

readln(a);

if (a > 0) and (a < 256) then writeln ("Klass C")

else if (a >= 256) and (a < 65535) then writeln("Klass B")

else if (a > 65535) then writeln("Klass A");

end.

2.

var

a : integer;

begin

writeln("Введите номер весеннего месяца");

readln(a);

if (a >= 3) and (a <= 5) then

begin

case a of

3 : writeln("Март");

4 : writeln("Апрель");

5: writeln("Май");

end;

end

else writeln("Это не весенний месяц");

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика