Напишите программу в pascal abc для первых n двузначных натуральных чисел вывести суммы цифр каждого числа

naumovvalera96 naumovvalera96    2   27.08.2019 11:50    4

Ответы
аолесдвда аолесдвда  20.08.2020 16:26
Var S,n,A:integer;
Begin
Write('n = ');ReadLn(n);
For n:= 10 to n+9 do
    Begin
    A:=n;
    S:=0;
    While A > 0 do
       Begin
       S:=S+A mod 10;
       A:= A div 10
       End;
    WriteLn('Сумма цифр ',n,' равна: ',S)
    End;
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика