Напишите программу, которая выводит на дисплей следующий график:

***
**
*
**
***


писать на python, используя вложенные циклы
Вложенные циклы.
Все звездочки (*) должны печататься одной функцией print(”*”, end=“”).

alinasun230503 alinasun230503    3   07.08.2020 15:53    1

Ответы
LuiZa87 LuiZa87  15.10.2020 15:46

def printGraph(size):

 for numI in range(size):

   row = ''

   for numJ in range(size - numI):

     row += '*'

   if row:

     print(row)

 for numI in range(size + 1):

   if numI == 1:

     continue;

   row = ''

   for numJ in range(numI):

     row += '*'

   if row:

     print(row)

 

print(printGraph(5))

Объяснение:


Напишите программу, которая выводит на дисплей следующий график: *** ** * ** *** писать на pytho
ПОКАЗАТЬ ОТВЕТЫ
Stak96 Stak96  15.10.2020 15:46

n = int(input("Введите размер >>> "))

for i in range(n, 0, -1):

   print("*"*i)

for i in range(2, n + 1, 1):

   print("*"*i)

============

Не забывайте нажать " ", поставить оценку и, если ответ удовлетворил, то выберите его как "Лучший"

Бодрого настроения и добра!

Успехов в учебе!


Напишите программу, которая выводит на дисплей следующий график: *** ** * ** *** писать на pytho
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика