Напишите программу, которая вычисляет сумму элементов последовательности целых чисел, поданных не её вход. Ввод заканчивается числом 0.

ruslansuxenco3 ruslansuxenco3    3   23.02.2021 01:34    4

Ответы
Lerka2004love Lerka2004love  23.02.2021 01:40

a = 1

A = []

while a != 0:

a = int(input())

A.append(a)

A.pop()

print(sum(A))

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
jdhhdd jdhhdd  23.02.2021 01:40

def func(A):

 summ = 0

 a = int(input())

 if a != 0:

   A.append(a)

   return(func(A))

 else:

   for i in A:

     summ += i

 return summ

A =[]

print(func(A))

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика