Напишите программу, которая бы выполняла переводединиц измерения. за основу можете взять код, в уроке.в программе должны быть: 1. ввод значения – функция 2. перевод единиц измерения.3. вывод значения – функция на свое усмотрение, можете усовершенствовать програм-му, дополнив разными функциями. выбор единиц измеренияна ваше усмотрение. результате будет такая формула: m = n * 1024,где n – число, которое ввел пользователь,а m – результат вычислений.чтобы выполнить обратное преобразование, т. е. из ме-габайтов в гигабайты, необходимо делить на 1024. такимобразом, формула имеет вид: m = n ÷ 1024,где n – число, которое ввел пользователь,а m – результат вычислений.уже минут 30 пытаюсь не получается

Uoywex Uoywex    2   10.04.2019 19:58    11

Ответы
whuwheuh123 whuwheuh123  29.05.2020 05:35

Для Python:

def UnitsConversion():

   n = int(input("Введите число для конвертации: "))

   rule = str(input("Нажмите 1, чтобы конвертировать в килобайты и 2, \

чтобы конвертировать в гигабайты: "))

   if rule == "1":

       m = n*1024

       print(m)

   else:

       m = n/1024

       print(m)

Объяснение:

1)Объявляем функцию UnitsConversion (можно назвать как угодно, без параметров в данном случае);

2)Ждем ввода пользователя при и сразу же конвертируем ввод в число при чтобы Питон мог совершать над ним мат. операции;

3)Спрашиваем, что нужно сделать: перемножить или поделить. В качестве ответа ждем строку, состоящую из "1" или "2", конвертируется ввод в строку при Если не использовать str(), то по умолчанию input() всегда будет строкой, но чтобы не путаться в данном примере, я использовал str().

4)Проверяем условия: если ввод был 1, то m будет произведение чисел, если не 1, то деление чисел, и также вывод ответа с

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика