tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу в с++ проверить
Написать программу в с++ проверить входит ли в заданную последовательность символов каждая из букв слова key
Natasha7554
2 09.09.2019 20:20
3
Ответы
KrasnovaLu82
07.10.2020 03:55
Кодяра ниже
#include <iostream>#include <string>using namespace std;int main() { setlocale(LC_ALL, "Russian"); string key = "key", buffer; cout << "Введите последовательность: "; cin >> buffer; bool *bitmap = new bool[key.length()]; for (int j = 0; j < key.length(); ++j) bitmap[j] = false; for(int i = 0; i < buffer.length(); ++i) for(int j = 0; j < key.length(); ++j) if (buffer[i] == key[j]) bitmap[j] = true; for (int j = 0; j < key.length(); ++j){ cout << "\"" << key[j] << "\""; if (bitmap[j]) cout << " есть!" << endl; else cout << " нет!" << endl; } system("pause"); return 0;}
Кодяра выше
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
27Alisa371
27.07.2019 19:40
Создать таблицу успеваемости в excel в редакторе excel создайте таблицу успеваемости, которая должна содержать не менее 10 оценок 10 учеников. три оценки должны быть оценками...
boha3
12.04.2020 10:20
Сколько Кбайтов составляют 2 в степени 14 битов?...
lehaguy
12.04.2020 10:19
За заданими функцією y=f(x), проміжком та кроком сформувати двовимірний масив значень функції (масив зберігає значення змінної (x) та відповідне значення функції (y)). Знайти...
2016mashamulalp0500j
12.04.2020 10:19
Сколько битов содержит 1/256 Кбайта?...
Ira511
12.04.2020 10:19
Напишите программу, которая находит номер максимального элемента массива. Входные данные В первой строке задается одно натуральное число N, не превосходящее 1000 – размер массива....
yil
12.04.2020 10:18
2. ответить на во а) Дана команда: CIRCLE (420,150),25,6 Чему равны: координата Y, радиус окружности, номер цвета? б) Дана команда: CIRCLE (420,150),25,6, 3.5, 1.2 Назовите...
Artemov9Artem
12.04.2020 10:04
Какое будет решение этой задачи?ЭВМ запрашивает: “Сколько будет 2 + 2?”. Если ответ верен, то отвечает: “Молодец!”. В противном случае: “Запомните: 2 + 2 = 4!”....
Vgenika
12.04.2020 09:59
№1 Для чего предназначен протокол TCP? * 1 Для того чтобы задать маршрут движения пакетов: определяет адресацию при передаче информации и обеспечивает организацию транспортировки...
YourselfRuelfddd
12.04.2020 09:59
Что такое сетевой протокол? * 1 Это набор инструментов, позволяющих осуществить соединение и обмен информацией между двумя и более включёнными в сеть устройствами. 2 Набор...
miha115
12.04.2020 09:59
Вычислите разрешающую в точках на миллиметр для (1 дюйм = 2,54 см):манипуляторов;сканеров....
Популярные вопросы
Найдите число: 1/4 которого равна 1/8...
2
Составить вопросы которые начинаются на: когда? ; где? ; почему? ; на тему...
1
Решите и объясните, как решать. у трикутника зі стороною 10 см і висотою...
1
Сколько свинок можно разместить в корзине воздушного шара, если ширина-...
3
Дед собрал 54 кг яблок и разложил их поровну в 6 корзин. на базар он отвёз...
1
Как определить лицо глаголов времени? пример...
3
Определите площадь квадрата со стороной 6 см !...
2
Составить сложное предложение состоящие из 6 простых...
3
Написать сочинение на тему пейзажи и их роль в повести тарас бульба (если...
1
Написать 10 слов 1 го скл 10 слов 2 го скл 10 слов 3 го скл, написать...
1
#include <iostream>#include <string>using namespace std;int main() { setlocale(LC_ALL, "Russian"); string key = "key", buffer; cout << "Введите последовательность: "; cin >> buffer; bool *bitmap = new bool[key.length()]; for (int j = 0; j < key.length(); ++j) bitmap[j] = false; for(int i = 0; i < buffer.length(); ++i) for(int j = 0; j < key.length(); ++j) if (buffer[i] == key[j]) bitmap[j] = true; for (int j = 0; j < key.length(); ++j){ cout << "\"" << key[j] << "\""; if (bitmap[j]) cout << " есть!" << endl; else cout << " нет!" << endl; } system("pause"); return 0;}
Кодяра выше