Написать программу в паскалabc даны 3 числа. определить, можно ли построить треугольник с указанными сторонами.

luchik1608 luchik1608    1   19.06.2019 02:10    1

Ответы
Maruua1 Maruua1  15.07.2020 13:24
Program triangle;
var
max,a,b,c,s:integer;
begin
readln(a,b,c);
max:=a; 
if b > max then begin 
 max:=b;
  s:=a+c; 
 if s > max then writeln('Мoжно')   
 else     
writeln('Нельзя');   
 end;   
if c > max then begin   
max:=c;   
s:=a+b;   
 if s > max then writeln('Мoжно')     
 else     
writeln('Нельзя');   
 end   
  else 
   s:=c+b;   
 if s > max then writeln('Мoжно')     
  else    writeln('Нельзя');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика