Написать программу на языке pascal ! задана окружность с центром в точке о (x0, y0) и радиусом r0. определить пересекается ли заданная окружность с осью абсцисс, если пересекается найти точки пересечения.

maxbf maxbf    3   29.09.2019 10:50    32

Ответы
BelkaNext BelkaNext  02.09.2020 10:19

var x0, y0, r0, x1, x2:real;

begin

readln(x0,y0,r0);

// уравнение окружности: (x-x0)^2+(y-y0)^2=r0^2

if r0*r0-y0*y0>=0 then

begin

x1:=-sqrt(r0*r0-y0*y0)+x0;

x2:=sqrt(r0*r0-y0*y0)+x0;

writeln('Точки пересечения: x1 = ',x1:4:2,' x2 = ',x2:4:2);

end

else writeln('Не пересекается');

end.

Пример:

1 1 2

Точки пересечения: x1 = -0.73 x2 = 2.73

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика