tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу на паскале:
Написать программу на паскале: вычислить 15 значений функции y=2-sin x из диапазона [pi/4, pi/2]
iwanttobelllllive
3 23.06.2019 09:10
3
Ответы
Dashylik228
19.07.2020 10:20
Const
pi=3.14159265;
n=15;
var
a,b,h,x,y:real;
begin
a:=pi/4; b:=pi/2;
h:=(b-a)/(n-1);
x:=a;
while x<=b+h/2 do { h/2 - компенсация накопления погрешности }
begin
y:=2-sin(x);
Writeln(x:7:5,y:8:5);
x:=x+h
end
end.
Результат выполнения программы:
0.78540 1.29289
0.84150 1.25436
0.89760 1.21817
0.95370 1.18444
1.00980 1.15328
1.06590 1.12478
1.12200 1.09903
1.17810 1.07612
1.23420 1.05612
1.29030 1.03908
1.34640 1.02507
1.40250 1.01413
1.45860 1.00629
1.51470 1.00157
1.57080 1.00000
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Дубак113
04.12.2020 14:32
До якого типу інформаційних систем належить система продажу залізничних квитків? Відповідь обґрунтуйте ...
зайка191111
04.12.2020 14:32
Ребята нужен метод половинного деления в программе эксел по это уравнение ребятки...
lubochka2
18.01.2021 14:58
Шо таке мова програмування? ...
MASTER2008
10.10.2020 17:58
Java 1. Розробіть код для створення масиву, елементами якого є букви: f, k, v, n, m, s. Виведіть на екран другий і п’ятий елементи масиву. 2. Розробіть код для створення масиву:...
luizaorlova99
14.12.2020 17:45
вариант 1. ((1 & 0) & 1) 2. ((1 v 0) v А) 3. (1 & 1) & (1 v 0) 4. ((1 v 0) v В) & (1 v A)...
Vika7791532
14.12.2020 17:45
ОТИ Вариант No2:2) Каковы принципы построения кодов, исправляющих одиночную ошибку в сообщении?Приведите пример построения кода Хемминга....
Mastermastack
14.12.2020 17:46
Скорость передачи данных по некоторому каналу связи равна 32 Кбит/с. Передача текстового файла по этому каналу связи заняла 10с. Определите, сколько страниц содержал переданный...
11Sone44ka11
04.05.2020 06:30
3.1 Переведи 12288 бит в килобайты 3.2. К какому типу алгоритма относится этот блок а) линейный b) циклический с) смешанный d) разветвляющийся СОР #1, 6 класс)...
byilyas
04.05.2020 06:30
8. Чтобы перейти к месту назначения, необходимо1.Щелкнуть гиперссылку.2.Щелкнуть Закладку.3.Найти самому.4.Поискать в справке....
Kirpiche
02.05.2019 07:21
Почему когда я включаю браузер firefox вылезает вот это? как это можно исправить?...
Популярные вопросы
Вычисли, используй переместительное и сочетательное свойство умножение 12×40...
3
Что включает в себя дыхательная система человека?...
3
Свопросами по параграфу начало смуты россии. 1)выдили причины смуты. 2)какими...
1
Дан фрагмент днк а-г-ц-т-т-ц-г-г-а-т достройте и определите длину данного...
1
Длина окружности 9,42 . найдите площадь круга , ограниченного этой окружностью...
3
Сколько километров в одной десятой части тонны в одной пятой части центнера...
2
Опишите речевую ситуацию, в которой уместно употребить фразеологизм один...
1
Город владимир год основания и год упоминания...
1
Синтасический разбор слова полтораста...
2
Продолжить слова после буквы щ,например щи.щука и дальше...
1
pi=3.14159265;
n=15;
var
a,b,h,x,y:real;
begin
a:=pi/4; b:=pi/2;
h:=(b-a)/(n-1);
x:=a;
while x<=b+h/2 do { h/2 - компенсация накопления погрешности }
begin
y:=2-sin(x);
Writeln(x:7:5,y:8:5);
x:=x+h
end
end.
Результат выполнения программы:
0.78540 1.29289
0.84150 1.25436
0.89760 1.21817
0.95370 1.18444
1.00980 1.15328
1.06590 1.12478
1.12200 1.09903
1.17810 1.07612
1.23420 1.05612
1.29030 1.03908
1.34640 1.02507
1.40250 1.01413
1.45860 1.00629
1.51470 1.00157
1.57080 1.00000