Написать программу которая может вычислить стоимость покупки с учетом скидки 10% есть сумма покупки больше 1000р

henriksenkids henriksenkids    3   31.05.2019 12:30    3

Ответы
ivan111111 ivan111111  01.07.2020 22:54
Var
  a: real;
  
begin
  while a <= 1000 do
  begin
    writeln('Введите сумму покупки > 1000р');
    readln(a);
    if a > 1000 then break
    else writeln('Ошибка! Введенная сумма покупки <= 1000p');
  end;
  writeln('Стоимость покупки с учетом скидки 10%:  ', a * 0.9);
end.
Данная программа проверяет, больше 1000 или нет, введенная стоимость покупки. Можно сделать проще без проверки:
var
  a: real;
  
begin
  writeln('Введите сумму покупки > 1000р');
  readln(a);
  writeln('Стоимость покупки с учетом скидки 10%:  ', a * 0.9);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика