На языке программирования c# написать программу, которая заполняет массив случайными числами через цикл foreach.

Mohim Mohim    2   26.03.2020 22:59    4

Ответы
Vlad29rus228999 Vlad29rus228999  12.10.2020 06:25

(Для версий C# 7.2 и выше)

using System;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           Span<int> storage = stackalloc int[10];

           Random r = new Random();

           foreach (ref int item in storage)

               item = r.Next(101)-50;

           foreach (ref readonly var item in storage)

               Console.Write($"{item} ");

       }

   }

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика