10. Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит «NO»). Программа должна вывести среднее арифметическое чисел, кратных 8, или вывести «NO», если таких чисел нет
на языке программирования питон

slayer75 slayer75    2   31.01.2021 15:06    15

Ответы
Alisa1Karimova Alisa1Karimova  02.03.2021 15:13

mass = [int(s) for s in input().split()]

k = 0

a = 0

for i in range(len(mass)):

   if mass[i] % 8 == 0:

       a += mass[i]

       k += 1

if k == 0:

   print('NO')

else:

   print(a / k)

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика