1. напишите программу, которая для последовательности натуральных чисел определяет их сумму. программа получает на вход количество чисел в последовательности и сами числа 2. измените программу так, чтобы определялось произведение чисел. 3. измените программу так, чтобы определялось количество чисел, заканчивающихся на 8

Vasilchenkodan Vasilchenkodan    2   13.08.2019 22:50    1

Ответы
MaxDeep MaxDeep  04.10.2020 17:09
1 и 3 пункты
var   n, s: integer;  
begin  
WriteLn('Введите последовательность. Конец ввода - 0');  
repeat    
ReadLn(n);    
if (n > 0) and ((n mod 10 = 8)) then      
s := s + n  
until n = 0;  
WriteLn('Сумма чисел, оканчивающихся на 3 или 9 = ', s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика