tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Заполнить случайным образом массив
Заполнить случайным образом массив из 10 целых чисел,подсчитать сколько элементов в массиве является четными числами
алекса146
2 30.08.2019 05:40
0
Ответы
funtya77
03.08.2020 11:41
const n=10;
var a:array[1..n] of integer;
i,k:integer;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
begin
a[i]:=random(51);
write(a[i]:4);
end;
writeln;
k:=0;
for i:=1 to n do
if a[i] mod 2 = 0 then k:=k+1;
writeln('k = ',k);
end.
Пример:
Массив A:
46 25 6 30 10 2 47 3 37 10
k = 6
begin
var a:=ArrRandom(10,1,50).Println;
Writeln('k=',a.Where(x->x mod 2=0).Count);
end.
Пример:
25 35 2 38 39 5 8 31 11 12
k=4
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Sawa1605
04.03.2021 19:01
какого назначение функции print?1.Для вывода результата на экран 2.Для того чтобы разделить строку 3.Для ввода данных 4.Для определения расширения файла...
asdf37
12.11.2020 07:24
1) переведите на язык алгебры логики следующие высказывания: неверно, что если погода пасмурная то дождь идет только тогда, когда нет ветра. 2) переведите на язык алгебры...
ЛеркаXD
12.11.2020 07:37
Создайте алгоритм действий По сылке...
beginfiu
13.07.2019 12:48
Как решить проблему. возникает она при запуске компа, в биос зайти не могу ...
STAS228917654321
13.07.2019 14:00
Дан двумерный массив 5 на5 заполненный случайными числами от - 20 до 20. напишите программу которая находит количество элементов оканчивающихся на 3...
yarlev88
13.01.2022 22:16
Выполнить перевод числа 0.67(75) (8система счисления) = X(16) до выявления периодичности дробной части. ответ впечатайте без указания основания системы счисления по образцу:...
sirius2010
13.01.2022 21:57
Трехзначное число, записанное в системе счисления по основанию 16, увеличивается вчетверо от перестановки последней цифры в начало числа. Чему равно максимальное из таких...
izabella131313
16.10.2020 02:09
There30 people on the island! Her teacher’s chair___brown. There are on the walls....
npapriko
16.10.2020 02:09
Вычисли.56 + 26 =47 + 26 =38 + 29 =56 - 38 =...
irinaa10
16.10.2020 02:09
10.13-Выпишите выражения, которые можно представить в виде квадрата и в виде куба одночлена, содержащие степени с натуральным показателем:4)0,16а^2b^6, 5)216a^6b^6...
Популярные вопросы
2.укажите слово, в котором все звуки звонкие. 1) огород. 2) сдал....
1
Шоколадка,, алпенгольд стоит в 1,4 раза дороже, чем сникерс. вместе...
1
Какой частью речи является что чьи которого какие из них могут изменятся...
3
Два-три примера сырья , из которого получабт важные продукты...
2
Сделать эссе на тему: человек не делает ничего,если нет цели и не...
2
5м 85 дм+ 15 м 15 дм 8м 26 см - 99 см 69 ц 30 кг - 665 кг 6 кг - 5...
2
Визначте, який шлях (у метрах) пройшло тило за 10 c пид час ривноприскореного...
2
Дано угол abc=105градусов , уголabd : угол cbd=4; 11 .знайти уголabdи...
2
Известно, что − 15 c − 14 . выберите выражения, принимающие отрицательные...
2
Что такое косвенное влияние человека на природу...
2
var a:array[1..n] of integer;
i,k:integer;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
begin
a[i]:=random(51);
write(a[i]:4);
end;
writeln;
k:=0;
for i:=1 to n do
if a[i] mod 2 = 0 then k:=k+1;
writeln('k = ',k);
end.
Пример:
Массив A:
46 25 6 30 10 2 47 3 37 10
k = 6
begin
var a:=ArrRandom(10,1,50).Println;
Writeln('k=',a.Where(x->x mod 2=0).Count);
end.
Пример:
25 35 2 38 39 5 8 31 11 12
k=4