Задано натуральное число n. напишите программу, которая выведет на экран все числа: сначала число n, а затем числа от 1 до n - 1. входные данные вводится одно натуральное число, не превосходящее 1000 выходные данные выведите n - 1 натуральное число. числа должны быть разделены пробелами. знаю решение, но не могу понять как вывести сначала 5, всё перепробовал, но 5 всегда в конце

Yxxxzy Yxxxzy    3   20.08.2019 08:20    5

Ответы
krnshlpn krnshlpn  05.10.2020 06:57
 var i,N:integer;
begin 
веедите натуральное число не превосходящее 1000'); 
readln(N); 
writeln('Входное число=',N); 
for i:=0 to (N-1) do write(i,' ');
 end.

Пример работы: 
веедите натуральное число не превосходящее 1000
5
Входное число=5
0 1 2 3 4 
P.S.Если в условии от 1-го, а не от нуля, for i:=0 to (N-1) do write(i,' '); замени на for i:=1 to (N-1) do write(i,' ');

Лишняя информация, если тебе не нравится информатика: на сколько я понял, ты не мог понять как вывести сначала число 5. В моей программе это делает оператор writeln(N); Именно Writeln, а не Write. Почему? Потому что writeln произошло от слова line - линия, оно занимает целую строку. А Write мастит все в одну строку. Если нужно будет что-то рассказать и это будет в моих силах, я с радостью любому желающему.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика