Задания.
1. Опишите двумерный массив А, состоящий из 6 строк и 3 столбцов, элементами которого являются целые числа:
2. Опишите двумерный массив В, состоящий из 3 строк и 8 столбцов, элементами которого являются символы:
3. Дана матрица А размера 3x4. Отметьте в ней «крестиком» положения элементов А[1,3], А[2,3], А[2,4], А[3,2].
4. Дана матрица А размера 8 х 7 . В какой строке и в каком столбце стоят элементы?
А [1,7] в _ столбце, в __ строке;
А [5,3] в _ столбце, в __ строке;
А [8,2] в __ столбце, в __ строке.
5. Задана матрица А размера 5x7. Требуется вывести ее на экран так, чтобы каждая строка матрицы выводилась на экран с новой строки. Выберите фрагмент программы, в которой вывод выполняется правильно.
ответ:
1) For i:=l to 7 do
Begin
For j:=1 to 5 do
write(A[i, j] ) ;
Writeln;
End;
3) For j :=1 to 5 do
Begin
For i:=l to 7 do
write(A[i,j]);
Writeln;
End;
2) For i:=l to 5 do For j:=1 to 7 do write(A[i,j]);
Writeln;
End;
4) For i:=l to 5 do Begin
For j:=1 to 7 do write(A [i,j]) ; Writeln;
End;
6. Впишите в тексты программ операторы так, чтобы в результате были получены расположенные напротив них матрицы.
1) Program matrl;
Var Al:array[1..4,1..5] of byte;
i,j:byte;
Begin
End.
2) Program matr2;
Const n=4, m=5;
Var A2:array[1..n,1..m] of byte;
i,j:byte;
Begin
End.
3) Program matr3;
Const n=4, m=5;
Var A2:array[1..n,1..m] of byte;
i,j:byte;
Begin
End.
7. Составить программу.
Элементы двумерного массива – случайные числа, лежащие в диапазоне [0,40].
Найти минимальный элемент в каждом столбце массива.