tutotveti.ru
Информатика
задание на фото Номер 10.
задание на фото Номер 10. надо написать программу В ПАСКАЛЕ, сначала найти значения, а потом сравнить. Сравнить то я смогу сам, а вот значения a,b,c узнать не могу
Популярные вопросы
Является ли пропорцией 2,5: 0,1=10,доказать... 2 Короткий рассказ о героине поэмы женщины... 1 Найти массу и количество осадка который образуется при взаимодействии нитрата... 3 Соседние стороны параллелограмма равны 21 м и 28 м,сумма высот проведенных... 2 По учебника понаблюдайте за трудом животноводов напишет краткий отчёт о наблюдениях.... 3 Какие виды аварий связанные с выбросом радиоактивных веществ могут возникнуть... 1 Сравните два района россии. критерии сравнения: 1.положение района( окраинное,... 2 Сторона треугольника равна 8 корень из 2см, а прилежащие к ней углы равны... 3 Vet: hi,john.what s the rmatter? john: it s tom,my parrot. vet: oh,what s... 1 Решить вычислите1. tg(pi/4-a) если ctg a=1,22.tg(a-b) если tga=3, ctg b= -1/3... 3
ответы программы (наименьшее значение из трёх):
1) 0.0828638516274247
2) 0.164832693219929
3) 0.145644125326545
Два текста программы (отличия во вводе икс и нахождения наименьшего):
var
x,a,b,c: real;
begin
write('x= ');
read(x);
a:=Exp(Power(Sin(x),2));
b:=1+Exp(Abs(x))/(1+Ln(Abs(Power(x,1/3;
c:=Tan(x/2)/(2+0.8*Power(x,4));
writeln('a= ',a);
writeln('b= ',b);
writeln('c= ',c);
write('min= ');
if a<b then
if a<c then write(a) else write(c)
else
if b<c then write(b) else write(c);
end.
var x,a,b,c: real;
begin
x:=ReadReal('x=');
a:=Exp(Power(Sin(x),2));
b:=1+Exp(Abs(x))/(1+Ln(Abs(Power(x,1/3;
c:=Tan(x/2)/(2+0.8*Power(x,4));
writeln('a= ',a);
writeln('b= ',b);
writeln('c= ',c);
write('min= ',Min(Min(a,b),c));
end.