Задание 1 ( ). Составьте программу на Паскале для заполнения массива из 100 чисел случайными значениями из диапазона от -25 до 25. Подсчитайте в этом массиве количество положительных и количество отрицательных чисел.
Задание 2 ( ).
Заполните случайными числами в диапазоне от 1 до 20 два массива: А[1:20] и B[1:20]. Найдите и выведите на экран только те элементы этих массивов, значения которых совпадают.
Например, если А[2] = 8, В[2] = 8, то на экран надо вывести:
Номер: 2 значение: 8.
Если таких совпадений нет, то вывести на экран сообщение об этом.
В отчет включить тексты программ, результат работы программы в виде скриншота с отображением кода и результата.
ответ на 1
begin
var a := ArrRandom(100, -25, 25);
a.Println;
Writeln;
var пол := a.Count(p -> p > 0);
var отр := a.Count(p -> p < 0);
Write('положительных ', пол, ', отрицательных ', отр)
end.
Объяснение:
хз , получится или нет.
задание 9 класса