tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Задан массив k(n). и отрицательные
Задан массив k(n). и отрицательные элементы массива заменить на их квадраты. вывести их индексы и новые значения.
pamagiteplease
1 30.07.2019 07:00
4
Ответы
ashatsejtenov
03.10.2020 17:15
Const
i=10;
var k:array[1..i] of integer;
n:integer;
begin
writeln('Введите элементы массива');
for n:=1 to i do begin
read(k[n]);
if k[n]<0 then k[n]:=sqr(k[n]);
end;
for n:=1 to i do write(k[n], ' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
lusine07
25.08.2020 14:16
Как называется моментальное изменение скорости объекта действующее некоторое время ответ по-русски...
TokstoyLev
15.03.2021 10:58
Специализированный компьютер для для решения определённого круга задач, на котором работает один пользователь (в один момент времени), называется...
hetty
08.07.2019 07:30
Массив а вводится с клавиатуры. найти сумму его элементов с четными номерами, произведение отрицательных элементов, количество нечетных элементов. размер произвольный....
Нонс2
08.07.2019 07:30
Массив а вводится с клавиатуры. найти среднее арифметическое его элементов с нечетными номерами. размер вводим с клавиатуры ( =20)...
feho
08.07.2019 07:30
Найти произведение элементов, кратных 3 в массиве, заданном датчиком случайных чисел на интервале [-28, 27]. размер – 50...
tata20082
18.04.2020 15:24
1. Дана матрица размером 3х2. Найти произведение элементов матрицы. ( ) 2. Дана матрица размером 4х4. Найти среднее значение элементов массива. Найти номер элемента массива...
dedovu6
18.04.2020 15:24
Составьте программу на паскале для вычисление плотности тела RO через его массу m и его обьем v дано: M и V ( ввести) НАйти: RO (вывести)...
evgeniaberezka
18.04.2020 15:23
Определите значение переменной Х...
Petya109
18.04.2020 15:23
Оператор вывода write(9,17,25,10) Результат ?...
anonimno3
18.04.2020 15:23
Вылетает игра при запуске VPN (roblox) пишет про интернет соеденение что делать...
Популярные вопросы
Чего больше-юмористического или сатирического-в творчестве зощенко?...
3
Составить предложения о полётах в космос гагарина!...
3
На уроці мальвіна запропонувала учням виконати такий алгоритм: 1)задумай...
1
Решите посностью,! 1.мужчина-гемофилик женился на здоровой женщине, отец...
1
Каковы причины нарушения лексических норм? !...
1
Из каких соединений можно синтезировать по реакции вюрца: а)бутан , б) 2,3-диметилбутан,...
3
Из куска проволоки надо сделать каркасы треугольной пирамиды и куба. какой...
1
Вправильной треугольной пирамиде sabc рёбра са и св разделены точками k...
3
Какой тип развития у жесткокрылых; чешуекрылых; двукрылых и перепончатокрылых?...
2
Очем свидетельствует выполнение равенства (еп1+еп 1)ср = (еп2+еп 2)ср ?...
2
i=10;
var k:array[1..i] of integer;
n:integer;
begin
writeln('Введите элементы массива');
for n:=1 to i do begin
read(k[n]);
if k[n]<0 then k[n]:=sqr(k[n]);
end;
for n:=1 to i do write(k[n], ' ');
end.