задача 1: Написать программу для поиска наименьшего элемента в массиве, заданного случайным образом и состоящим из 12 элементов. задача 2: Написать программу для поиска в массиве, заданного случайным образом и состоящим из 20 элементов, элемента, равного 65​

Sabinafei Sabinafei    2   06.12.2020 15:50    5

Ответы
Камила15111 Камила15111  05.01.2021 15:51

program test1;

var r, minim, i: integer;

a: array[1..12] of integer;

begin

 for i:=1 to 12 do

 begin

   a[i]:= random(100);

 end;

 minim := a[1];

 for i:=1 to 12 do

 begin

   if minim > a[i] then

     minim:= a[i];

 end;

 writeln('минимальное значение=', minim);

end.

program test2;

var i: integer;

var poisk: string;

a: array[1..20] of integer;

begin

 for i:=1 to 20 do

 begin

   a[i]:= random(100);

 end;

 for i:=1 to 20 do

 begin

   if a[i] = 65 then

     poisk:=poisk + i;

 end;

 if poisk = '' then

   writeln('нет элементов массива со значением 65')

 else writeln('элемент(ы) массива со значением 65 ',poisk)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика