Язык с# 1.1 написать программу вычисления стоимости покупки с учетом скидки. если сумма покупки меньше 1000 руб., то стоимость покупки не изменяется, а если больше, то предоставляется скидка в 10%. 1.2 получить таблицу пересчета миль в километры (1 миля = 1,609344 км) для расстояний, не превышающих k км.

Martishevska Martishevska    3   20.09.2019 12:50    4

Ответы
simalivevl simalivevl  08.10.2020 04:35
     //Задача 1            Console.WriteLine("Введите количество товара");            string r = Console.ReadLine();            double n = Convert.ToDouble(r1) ;            double tovar = 250;            double sum = 0.0;            double skidka = 0.1;            double oplata;                      sum = tovar * n;            if (sum <= 1000){                oplata = sum;            }            else            {                oplata = sum - sum * skidka;            }
            Console .WriteLine("Колис товара=" + n + " Цена товара = " + tovar + " стоимость покупки= "+ sum +  " Оплата = " + oplata );            //Задача2            Console.WriteLine("Введите количество к км");            string r1 = Console.ReadLine();            double k = Convert.ToDouble(r1);            double q = 1.609344;            for (int i = 1; i < k + 1; i++)            {                Console.Write("км = " + i + " "); Console.WriteLine("миля = " + i / q);            }             Console.ReadKey();
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика