Язык программирования c# в visual studio
написать программу, которая выводит на экран квадрат пифагора
– таблицу умножения

teodormax teodormax    1   20.11.2019 19:19    5

Ответы
vikaivanyk vikaivanyk  10.10.2020 14:38

ответ:#include<stdio.h>

int main()

{

int y[10][10];// задаем двумерный массив y 10 строк, 10 столбцов  

  int i,j; // переменные целого типа, отвечающие за строки, столбцы

   for(i=1;i<10;i++) { //цикл по строкам

       for(j=1;j<10;j++){ //цикл столбца

           y[i][j]=i*j; //i это индекс строки, j – индекс столбца

           printf("%6d",y[i][j]); //выводим элементы на экран

       }

       printf("\n"); //\n - перевод на новую строку для корректного отображения нашей таблицы

   }

}

Объяснение:

//i*j происходит перемножение элементов начиная с еденицы, т.е 1*1=1, затем 1*2=2, 1*3=3 и т.д  

//когда j<10 т.е 1*9=9, будем умножать i=2, т.е 2* 1=2, 2*2=4 и т.д

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика