Язык программирования - c++. напишите программу, которая вводит натуральное число n и находит все совершенные чис- ла в диапазоне от 1 до n.

modamzubik modamzubik    1   19.09.2019 01:40    0

Ответы
alyaomelchenko alyaomelchenko  08.10.2020 01:13
#include <iostream>
using namespace std;

int main()
{
   int n = 0;
   cin >> n;
   for (int i = 1; i <= n; ++i) { 
      int a = 0;
      for (int j = 1; j < i; ++j) {
         if (i % j == 0) {
            a += j;
         }
      }
      if (a == i) {
         cout << i << endl;
      }
   }
   return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика