Язык - паскаль. в магазине продаётся шоколадка, стоимостью x рублей и y копеек. у нас есть a рублей b копеек. сколько можно купить шоколадок(f)? сколько у нас останется рублей(c)? сколько у нас останется копеек(d)? 15 ! ,

Aysyiu Aysyiu    3   07.10.2019 11:30    1

Ответы
Ivan700 Ivan700  10.10.2020 01:27
5.Пирожок в столовой стоит a рублей и b копеек. Определите, сколько рублей и копеек нужно заплатить за n пирожков. Программа получает на вход три числа: a, b, n и должна вывести два числа: стоимость покупки в рублях и копейках.
ПОКАЗАТЬ ОТВЕТЫ
kurbatovmaximp08xa1 kurbatovmaximp08xa1  10.10.2020 01:27
Var x,y,a,b,c,d,f:integer;
begin
read(x,y,a,b);
xy:=x*100+y;
ab:=a*100+b;
f:=ab div xy;
if ab-xy*f >100 then c:=(ab-xy*f) div 100 else c:=0;
d:= ab-xy*f;
writeln(f,’ шоколадок можно купить, а ещё останется ‘,c,’рублей и ‘,d,’копеек.’)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика