Язык pascal ! дан алгоритм: подпрограмма 1)ввести натуральное число m,n 2)если m=n перейти к п. 5, иначе к следующему пункту 3)если m> n, то m: =m-n; иначе n: =n-m 4)перейти к п. 2 5)передать значение m в основную программу 6) конец подпрограммы основная программа 1)ввести значение a,b,c,d 2)e: =a*d-b*c 3)f: =b*d. 4)если е=о , вывести значение е и перейти к п. 9, иначе перейти к следующему пункту 5)m: =|e|, n: =f; перейти к подпрограмме вычисления нод 6)g: =m; 7)e и f нацело разделить на g 8)вывести значение e и f на печать 9)конец программы нужно написать программу по данному алгоритму.

maximt025 maximt025    2   17.06.2019 04:00    0

Ответы
Dashka6969 Dashka6969  13.07.2020 21:17
Program ex2;
function nod(n,m:longword);
begin
  while n<>m do
      if n>m then
         n:=n-m
     else
         m:=m-n;
  nod:=m;
end;
var a,b,c,d,f,g:longword;
      e:longint;
begin
   read(a,b,c,d);
   e:=a*d-b*c;
   if e=0 then
       write('0')
   else
   begin
       f:=b*d;
       g:=nod(abs(e),f);
       e:=e div g;
        f:=f div g;
        write(e,'  ',f); 
   end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика