tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Язык c++. сформировать
Язык c++. сформировать массив из 12 элементов. вывести его на экран, выделив минимальный и максимальный элементы массива (например, восклицательными знаками).
Angelina000477
3 22.09.2019 14:20
1
Ответы
КристинаМазова
08.10.2020 09:51
#include <iostream>
using namespace std;
int main() {
int n=12, imax=0, imin=0;
int a[n];
srand(time(NULL));
cout<<"array:"<<endl;
for (int i=0; i<n; i++)
{
a[i]=rand() % 50;
cout<<a[i]<<" ";
}
cout<<endl;
for (int i=1; i<n; i++) {
if (a[i] > a[imax]) imax = i;
if (a[i] < a[imin]) imin = i;
}
for (int i=0; i<n; i++) {
if (i == imax || i == imin) cout << " ! " << a[i] << " ! ";
else cout << a[i] << " ";
}
cout<<endl;
return 0;
}
Пример:
array:
31 0 13 29 13 34 33 42 40 26 48 24
31 ! 0 ! 13 29 13 34 33 42 40 26 ! 48 ! 24
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Horsik1Konnik
09.04.2021 12:36
розробити проєкт на основі знань з програмування, отриманих в 8 та 9 класах, який розв язує компетентнісну задачу. Використати задачі на опрацювання табличних величин та візуалузацію...
alinaklepcova
20.03.2020 18:02
С ГНЧЭ-1» — сложное электронное устройство, выдающее каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих...
helpplease14
20.03.2020 18:03
Сколько различных решений имеет система логических уравнений? Скрин прикрепил....
зефирка39
20.03.2020 18:04
Какая формула появится в ячейке D1, если скопировать в нее формулу из ячейки C2=A$2+$B$3?...
ДжулиТян
20.03.2020 19:10
перевести с Pascal в Phyton uses crt; var a,b,c,d,e,f,i,nb,nc:integer; function hod(n,x,y:integer):boolean; begin case n of 1:hod:=((abs(x-e)=1)and(abs(y-f) =1))or((abs(x-e)...
sergeicyupka
20.03.2020 19:13
B = 1a = b * 2a = a + bprint( a= /a)a=?...
katy244
20.03.2020 19:48
сделать. Створення бази даних в середовищі СУБД Microsoft Office Access. Робота з об’єктами бази даних....
Diankamilanka2005
20.03.2020 20:19
Написать программу на языке Питон: Ввести 3 числа с клавиатуры. Вычислить их сумму (+) и произведение (*) и вывести их на экран....
lesja021
20.03.2020 20:32
Рассчитай объём видеопамяти, необходимой для хранения графического изображения, занимающего весь экран монитора с разрешением 800×600 и палитрой из 65536 цветов....
dfghfgjkhfdjkgh
20.03.2020 21:08
Почему не работает псевдоэлемент ::after в коде?...
Популярные вопросы
78 десятков сколько это будет в еденицах...
2
Формула. относительная атомная и молекулярная масса h2so4 naoh c2h5oh...
1
Полный синтаксический разбор предложение старательная пчёлка собирала с цветов...
3
Каковы роль церкви и священников, верховенство власти, язык богослужения,...
1
вертолёт совершил два вылета. в первый раз он летал 2ч. со скоростью 200км/ч....
2
Сочинение о каком-нибудь памятном событие так чтобы была понятна основная...
2
Напишите все частицы только частицы...
2
Log x по основанию 2 = 9 - (0,2 в степени (log 0,25 по основанию 5))...
1
Образ земли в слове о полку игореве . , из интернета не берите, кратко и своими...
2
Какое слово не содержит орфограмму проверяемая гласная в корне слова голодать...
3
using namespace std;
int main() {
int n=12, imax=0, imin=0;
int a[n];
srand(time(NULL));
cout<<"array:"<<endl;
for (int i=0; i<n; i++)
{
a[i]=rand() % 50;
cout<<a[i]<<" ";
}
cout<<endl;
for (int i=1; i<n; i++) {
if (a[i] > a[imax]) imax = i;
if (a[i] < a[imin]) imin = i;
}
for (int i=0; i<n; i++) {
if (i == imax || i == imin) cout << " ! " << a[i] << " ! ";
else cout << a[i] << " ";
}
cout<<endl;
return 0;
}
Пример:
array:
31 0 13 29 13 34 33 42 40 26 48 24
31 ! 0 ! 13 29 13 34 33 42 40 26 ! 48 ! 24