tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Взаданном массиве вещественных
Взаданном массиве вещественных чисел определить количество элементов меньших среднего арифметического значения.
nikitosik1296
2 28.05.2019 05:20
0
Ответы
rukozhop2002
15.05.2020 22:26
CONST N=5;
var
x:real;
i:integer;
ar:array[1..N] of real;
begin
for i:=1 to N do begin
readln(ar[i]);
x:=x+ar[i];
end;
x:=x/i;
for i:=1 to N do if (ar[i] < x) then write(ar[i],' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
bodnarhuk83
26.05.2019 12:20
Даны действительные числа a, b, c. даны действительные числа a, b, c. найдите все решения квадратного уравнения ax2 + bx + c = 0. формат входных данных даны три действительных...
даша33100
03.04.2020 16:15
Задание 1.Составить блок-схемы линейных алгоритмов. 1. Даны длины сторон треугольника A, B, C. Найти периметр и площадь треугольника. 2. Вычислить расстояние между двумя точками...
Polya6Б
03.04.2020 16:18
Заполнить массив 20-ю случайными целыми числами из промежутка [-10; 25] и вывести на экран элемента соответствующий индексу Х, значение которого вводится с клавиатуры. Если такого...
АсяГордиенко
03.04.2020 16:28
Заполнить массив 10-ю случайными целыми числами из промежутка [5; 18] и вывести на экран каждый третий элемент....
Mahb
21.06.2019 22:50
Напишите программу,которая запрашивает 2 числа,из которых к большему прибавляется 1,а у меньшего вычитается 1....
Azozylya
21.06.2019 22:50
Вклассе 30 человек, каждый из которых поёт или танцует. известно, что поют 17 человек, а танцевать умеют 19 человек. сколько человек поёт и танцует одновременно?...
popovamelanaliceysi
20.09.2019 04:40
Перевести число в25,с3 из шестнадцатеричной системы во 2,8,10 с решением...
crosser001
20.09.2019 04:40
представления алгоритма с фигур называется а)программа б)алгоритм в)блок схема г)исполнитель...
Springtrap222134124
20.09.2019 04:50
Исполнитель робот,система команд исполнителя робот?...
Анечка04Анюта
03.10.2019 12:20
Люди, у меня в ноутбуке стоит 4gb оперативной памяти, но в играх тратится максимум 2 gb, как это исправить? 2133gb в cs: go 2133 в gta 5 online...
Популярные вопросы
Брусок лежить на дошці. Якщо піднімати один кінець дошки, то при куті нахилу...
3
Сколько процентов информации мы передаем друг другу невербально?...
3
3(х+5)=5-2х 7х+2(8-3х)=5х+20...
1
надо сделать задание до 20:00...
3
адекватного ОТВЕТА надеюсь на вас...
3
1 Выбери правильную форму глагола. Two days ago I ( am, was, were) at my friends...
1
пожайлуста С любым задание м...
3
Өнімділік пен уақыт формуласы қалай...
1
От мотка ленты сначала отрезали 7 м, а затем еще 10 м. После этого в мотке...
1
Ребят прям Заполни пустые места о применении третьего признака равенства треугольников:...
1
var
x:real;
i:integer;
ar:array[1..N] of real;
begin
for i:=1 to N do begin
readln(ar[i]);
x:=x+ar[i];
end;
x:=x/i;
for i:=1 to N do if (ar[i] < x) then write(ar[i],' ');
end.