tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Вычисление ожидания оформить
Вычисление ожидания оформить в виде процедуры.(pascal)
energo5165
3 12.07.2019 05:10
0
Ответы
Vikusyadubenko
03.10.2020 01:51
var
m:real;
n,i:integer;
procedure MathW(var i:integer;var m:real);
var
x,p:real;
begin;
write('Введите значение ',i,':');
readln(x);
write('Введите вероятность ',i,':');
readln(p);
m:=m+x*p;
end;
begin;
write('Введите количество испытаний:');
readln(n);
for i:=1 to n do
MathW(i,m);
write('Result:',m);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
tamilyamehtiev
13.09.2019 05:50
Цветное изображение с палитрой из 8 цветов имеет размер 6x8 точек. какой информационный объем в байтах имеет изображение?...
Brot2007
13.09.2019 05:50
Дан одномерный целочисленный массив, заданный случайными числами на промежутке [-50; 50]. заменить в массиве все отрицательные элементы на элементы им противоположные...
galinadik84
13.09.2019 05:50
(не ошибки) под…………эвм понимают описание устройства и принципов работы компьютера, достаточное для пользователя и программиста. 2. указание на последовательность...
liza1367
13.09.2019 05:50
154 написать программу, которая выводит минимальный элемент введенного с клавиатуры массива целых чисел. ниже представлен рекомендуемый вид экрана во время работы...
svetagres
13.09.2019 05:50
Решить 20а+12е. напишите с объяснением....
Anvar666
13.09.2019 05:50
Пусть а=«первая буква имени - гласная» , в = «четвёртая буква имени согласная». найдите значение логического выражения āvb для следующих имен: 1)елена 2)вадим 3)...
arhangel33
13.09.2019 05:50
На языке vba для excel заполнить диапазон ячеек в4: н9 случайными положительными и отрицательными числами. упорядочить их по возрастанию по каждому столбцу....
Xoroshiyi
13.09.2019 05:50
написать комментарии к каждой строке. sub aaa() randomize timer for r = 4 to 9 for c = 2 to 8 cells(r, c) = 10 * rnd - 5 next c next r for c = 2 to 8 set d = range(cells(4,...
ponia
13.09.2019 05:50
Напишите, , программу, которая вычисляет сумму всех двухзначных чисел, кратных 3. программа на паскаль....
максим5695
13.09.2019 06:00
Составьте не менее трех вариантов программы определения наименьшего из трех данных...
Популярные вопросы
Зависимость координаты х тела от времени t имеет вид: х=1+2t+3t2....
3
Решить ) begin11°(в №3). даны два ненулевых числа. найти сумму,...
2
Диагональ боковой грани правильной четырехугольной призмы равна...
3
Сравните числа.а=две седьмые корень из семи и в=одна четвертая...
3
Решите : высота 5 одинаковых полок в шкафу равна 2 метра .чему...
2
Вкаком падеже слово лес в предложение: мы часто ходили в лес....
3
Ныне самый старый кикаир дерево диаметр ствола 16метров 28человек...
1
Нужно подобрать подходящие по смыслу прилагательные к слова мост,...
3
(2x-1)в квадрате - (x-2)в квадрате = 0 решить !...
3
Смелого пуля боится,смелого штык не берёт. найти прилагательные...
1
m:real;
n,i:integer;
procedure MathW(var i:integer;var m:real);
var
x,p:real;
begin;
write('Введите значение ',i,':');
readln(x);
write('Введите вероятность ',i,':');
readln(p);
m:=m+x*p;
end;
begin;
write('Введите количество испытаний:');
readln(n);
for i:=1 to n do
MathW(i,m);
write('Result:',m);
end.