tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Введите с клавиатуры число n
Введите с клавиатуры число n и запишите в массив первые n простых чисел
amina555658
2 21.08.2019 09:00
1
Ответы
katka55555
05.10.2020 08:59
Var i, k, n, count, primes: word;begin
readln(n);
k := 1;
primes := 0;
while primes < n do begin
count := 0;
for i := 1 to k do begin
if k mod i = 0 then inc(count)
end;
if count = 2 then begin
write(k, ' ');
inc(primes)
end;
inc(k)
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Kadilya
28.11.2020 09:05
A ограничение по времени на тест2 s. ограничение по памяти на тест256 MB вводstandard input выводstandard output AdiZer0 готовясь к экзамену, узнал о интересных числах. Будем называть...
нона57
28.11.2020 09:10
Писать только на алгоритмическом языке!) 1) Даны натуральные числа A и B. Напишите алгоритм, чтобы найти наибольшее из этих двух чисел. 2) Даны три числа: A, B и C. Найдите большее...
mazyrovavlada
20.04.2021 14:13
Решение нужно, бэндиты, как можно бырее...
алина200423
26.06.2019 05:30
Для заданного количества суток (s) определите количество часов (h), минут (m) и секунд (c). составьте блок схему и напишите программу на языке паскаль....
annaps4
23.10.2019 19:22
Запишите в десятичной системе счисления чисо, представленное в римской системе счисления так: mmcmxlviii 2.записать развернутую запись числа( в десятичной системе счисления): а)385,6;...
нурбол5
23.10.2019 19:18
37 заштрихуйте на кругах эйлера области которые соответствуют результатам поиска по запросам...
MiracleOne
23.10.2019 19:17
Что означают знаки, отмеченные зеленым цветом? ...
ЛераБедердинова
23.10.2019 19:17
Сколько натуральных чисел между а=101010101(2) и в=д 9(16)...
kbvovap0drsr
23.10.2019 19:17
Составьте таблицу истинности для следующих логических выражений...
xnxnxnxnx
11.05.2020 18:05
па-беларуску паутара рубля...
Популярные вопросы
Какое количество теплоты выделится при полном сгорании 100кг антрацита?...
2
Нужен девиз и название для команды на урок по роману дубровский ! !...
2
Відредагувати речення.1. оголошується наступний порядок денний.2. іван не мав...
3
Вромбе угол между диагональю и стороной равен 25 градусов. найти углы ромба...
1
Различаются ли по лексическому значению слова : стелю стелет стелешь? ?...
1
Пешеход и велосипедист отправились одновременно на встречу друг другу из двух...
1
Докажите что при любом значении а верно неравенство 1+2а в квадрате больше или...
3
Это архитектурное сооружение было построено в 16 веке. иностранцы называли его...
3
Два сообщения содержат одинаковое количество символов. количество информации...
3
Определить степень окисления атомом элементов , назвать вещества: so2. caci2....
1
readln(n);
k := 1;
primes := 0;
while primes < n do begin
count := 0;
for i := 1 to k do begin
if k mod i = 0 then inc(count)
end;
if count = 2 then begin
write(k, ' ');
inc(primes)
end;
inc(k)
end;
end.