Втурбо паскале уже нужно составить программу для обработки массива содержащего 10 целых числе. определить максимальный элемент массива. выполнение каждого логического блока программы оформить в виде отдельных процедур

Super364 Super364    2   13.06.2019 22:40    0

Ответы
arzuaes arzuaes  10.07.2020 19:23
Uses crt;
var i,j,k,n,max:integer; a:array[1..100] of integer;
procedure rmassr;
begin
    for i:=1 to n do
    a[i]:=random(10);
end;
procedure rmassy;
begin
    for i:=1 to n do
    readln(a[i]);
end;
procedure maxe;
begin
max:=a[1];
    for i:=2 to n do begin
        if a[i] > max then max:=a[i];
    end;
    writeln('max element = ', max);
end;
procedure wmass;
begin
    for i:=1 to n do
    write(a[i],' ');
    writeln;
end;
begin
clrscr;
randomize;
write('Длина массива'); readln(n);
write('1-random; 2- в ручную '); readln(k);
if k=1 then rmassr()
else rmassy();
wmass();
maxe();
readln
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика