Все сови : написать программу котораяопределяет является ли число четнымили его запись окончательно целая 7

buzovkina81 buzovkina81    3   16.09.2019 18:50    4

Ответы
umma95 umma95  07.10.2020 20:18
Var
num: integer;
begin
read(num);
if num mod 2 = 0 then write('Число четное') else write('Число нечетное');
end.
ПОКАЗАТЬ ОТВЕТЫ
sashkoefymets sashkoefymets  07.10.2020 20:18
Var
  n:integer;

begin
  Write('n = '); Read(n);
  if (n mod 2=0) then Writeln('Число четное')
  else begin
    Write('Число нечетное и оно ');
    if Abs(n mod 10)<>7 then Write('не ');
    Writeln('оканчивается цифрой 7')
    end
end.

Примеры
n = 3538
Число четное

n = 642301
Число нечетное и оно не оканчивается цифрой 7

n = 6306547
Число нечетное и оно оканчивается цифрой 7

n = -546347
Число нечетное и оно оканчивается цифрой 7
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика