Впаскале составить прогу.если можно на уровне 9го класса составить программу для вычисления значения функции на отрезке [a,b] с шагом 1.

severina3 severina3    1   25.06.2019 09:10    1

Ответы
Фикус04 Фикус04  02.10.2020 11:00
Мы взяли функцию f(x) = sin(x)-2*cos(x).
В процедуру-функцию function можно вставлять любые функции

program func;
uses Crt;
var a, b, x, y:real;

function f(var x:real):real;
  begin
     f:=sin(x)-2*cos(x);
   end;

begin
 ClrScr;                {Очистка экрана}
 Write (' a= ');  ReadLn(a);
 Write (' b= ');  ReadLn(b);
 WriteLn;
 x:=a;
 while x<=b do
   begin
     y:=f(x);
     WriteLn ('y(', x:1:0, ')= ', y:4:2);
     x:=x+1;
    end;
ReadLn;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика