Впаскале. напишите программу по нахождению периметра и площади шестнадцатиугольника

ирина1834 ирина1834    3   06.10.2019 13:40    1

Ответы
Катя7544 Катя7544  09.10.2020 23:40

Привет!


Периметр:


program x;

var

y,x1,x2,x3,x4,x5,x6,x7,x8,x9,x10,x11,x12,x13,x14,x15,x16:integer;

begin

writeln('Введите длины всех сторон шестнадцатиугольника, см: ');

readln(x1,x2,x3,x4,x5,x6,x7,x8,x9,x10,x11,x12,x13,x14,x15,x16);

y:=x1+x2+x3+x4+x5+x6+x7+x8+x9+x10+x11+x12+x13+x14+x15+x16;

writeln('Периметр данного шестнадцатиугольника,см= ',y);

readln;

end.


Площадь:

var a : integer;  

S : real;  

function SquareTr(a : integer) : real;  

begin  

SquareTr := (sqrt(3)*a)/2  

end;  

BEGIN  

writeln('Введите сторону шестнадцатиугольника: ');  

ReadLn(a);  

S := 16 * SquareTr(a);  

Writeln('Площадь шестнадцатиугольника со стороной а, равна ', S:16:16);  

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика