Впаскале, через case of составить программу для начисления зарплаты согласно следующему правилу: если стаж работы сотрудника менее 5 лет, то зарплата 50$., при стаже работы от 5 до 15 лет — 100$., при стаже свыше 15 лет зарплата повышается с каждым годом на 10$, превышающем 30 лет она составляет 300$

tv7antena tv7antena    1   05.10.2019 10:01    4

Ответы
Енотuк Енотuк  09.10.2020 21:25

var

old:integer;

begin

writeln('Введите стаж');

readln(old);

case old of

0..4: writeln('50$');

5..15: writeln('100$');

16..30: writeln(100+(old mod 15)*10);

31..100: writeln('300$');

end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика