Водномерном массиве вычислить долю четных положительных элементов массива. написать программу на с#.

Софія133 Софія133    3   19.09.2019 02:01    0

Ответы
aasssddddddd aasssddddddd  08.10.2020 01:14
Static void Main(string[] args)       
{           
     int count = 0;           
     Console.Write("Введите размерность массива: ");           
     int n = Convert.ToInt32(Console.ReadLine());           
     int[] mas = new int[n];           
     Console.WriteLine("Заполните массив: ");           
     for (int i = 0; i < n; i++)           
     {               
          Console.Write("\t{0} элемент массива: ", i + 1);             
          mas[i] = Convert.ToInt32(Console.ReadLine());           
     }           
     for (int i = 0; i < n; i++)               
          if (mas[i] > 0 && mas[i] % 2 == 0)                   
               count++;           
     Console.WriteLine("Из {0} элементов массива {1} элементов являются положительными четными",n,count);           
     Console.WriteLine("{0}%  элементов являются положительными четными", (double)count/n*100);           
     Console.ReadLine();       
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика