Вмассиве хранятся сведения о количестве осадков(в мм),выпадавших ежедневно в сентябре.составьте программу,которая подсчитывает количество дождливых дней (h [i] > 0) люди ! надо,кому не

MaМа MaМа    2   14.08.2019 17:50    9

Ответы
девочка261 девочка261  04.10.2020 19:19
Const N = 30; // Количетсво дней
var
i,count:integer;
h: array [1..N] of integer;
begin
count:=0;
writeln('Введите количество осадков');
for i:=1 to N do
read(h[i]);
for i:=1 to N do
if h[i]>0 then
count:=count+1;
writeln('Количество дождливых дней ', count)
end.

В первой строке указываем количество дней. Это константа N
Далее объявляем, что переменная count равна 0. В этой переменной мы будем хранить количество дней с осадками.
Далее мы вводим с клавиатуры 30 чисел, показывающих осадки.
Потом мы проверяем, если число в массиве больше нуля, то мы увеличиваем count на единицу. Тоесть прибавляем +1 день с осадками.
В конце выводим количество дней с осадками
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика